HowTo: Debian Squeeze und E17 für Netbooks

Ich wollte unbedingt E17 in Verbindung mit Debian auf meinem Netbook (Lenovo S10-2) installieren. Da es einige Unwegbarkeiten zu umgehen gibt, fasse ich meine Vorgehensweise in diesem HowTo zusammen.

Enlightenment E17


Vorbereitung

Als erstes Installiert man Squeeze mit Xfce als Desktop, dazu packt man ein Installationsmedium für Testing auf einen bootfähigen USB-Stick und installiert Squeeze mit Xfce wie bei einer ganz normalen Installation. Sollte keine Auswahl des Installationsmenues erscheinen, ruft man die Installation mit folgendem Kommando am aufblinkenden Prompt auf:

install desktop=xfce

Installation

Nachdem Squeeze erfolgreich installiert wurde, geht es an die Nachinstallation von E17 und der Software die man verwenden möchte. Ich habe meine sources.list mit dem Debian sources.list-Generator generieren lassen.
Wer seine sources.list lieber manuell konfiguriert fügt das E17-Repo manuell ein.

Repository:
deb http://packages.enlightenment.org/debian squeeze main extras

Key:
wget -q http://packages.enlightenment.org/repo.key -O- | apt-key add -

Anschließend findet man unter Synaptic die Pakete:

e17
emodule-xxx
...


Achtung:
Exalt und Entrance derzeit nicht installieren, da Entrance bei mir abstürzt und der Networkmanager Exalt nur WEP-Verschlüsselung beherrscht.

Man installiert jetzt einfach e17 und die Module, die man benötigt/möchte.
Schon kann man in GDM Enlightenment auswählen😀

Beim Start erscheint der Einstellungsdialog von E17, hier wählt man am besten bei der Einrichtung „Netbook“, da mit dieser Einstellung z. B. Compositing deaktiviert ist.

Anpassungen:

Damit alles rund läuft, gerade was das Netzwerk angeht, muss man noch etwas Hand anlegen.
Wicd, funktioniert mit Broadcom-Hardware derzeit leider nicht, da man (oder zumindest ich) den Treiber unter den Einstellungen nicht auf b43 umstellen kann (Die Einstellungen lassen sich nicht aufrufen). Deshalb deinstalliert man

wicd, wicd-deamon, wicd-gtk

und installiert dafür

network-manager-gnome

Damit man den Gnome-Networkmanager aufrufen kann, muss man jetzt noch bei Enlightenment das Modul „Infobereich“ laden und in der Leiste einfügen. Jetzt kann der Networkmanager mit dem Befehl:

nm-applet

gestartet werden.

Eine Verbindung zu WPA (2)-gesicherten Netzwerken funktioniert, aber leider vergisst der NW den Key nach jedem Neustart. An diesem Thema bin ich dran und poste eine Lösung in diesem Artikel, sobald ich etwas herausfinde.

Ich werde diese Anleitung in den nächsten Tagen evtl. noch etwas überarbeiten und einige Dinge noch ausführlicher beschreiben.

    • tomtomtom
    • 25. April 2010

    Geht das nicht über ne Netinstall-CD? Wüsste jetzt nicht, warum ich da unbedingt XFCE installieren muss, wenn nicht nötig…

  1. Natürlich geht es i. d. R. auch ohne Xfce. Bei mir hat dann zwar der Xserver funktioniert, ein Login über GDM bzw. Entrance war leider nicht möglich…😦

  2. Das ist ein cooles Hintergrundbild.

    • quintusfelix
    • 26. April 2010

    Interessante Idee E17 auf nem Netbook – vor allem der Look dürfte relativ selten sein. Könntest Du Details zu Deinem Desktop posten, also Hintergrundbild, wie Du das Menü so hinbekommen hast usw. damit man den auf dem Screenie abgebildeten Desktop nachbauen kann?
    Grüße undso,
    der glückliche fünfte

    • Werde ich machen, wenn ich wieder Zuhause am Netbook bin🙂

      Also das Theme heißt Grunge
      Und in Shelf1 hab ich noch zusätzlich die Module Benachrichtigungsfenster, Mixer und Infobereich hinzugefügt.

        • quintusfelix
        • 28. April 2010

        Danke! Hast Du auch einen Tipp wie man GTK, also das Fensteraussehen so anpassen kann, dass es nicht wie ein totaler Fremdkörper auf diesem stylischen Desktop wirkt?

  3. quintusfelix :

    Danke! Hast Du auch einen Tipp wie man GTK, also das Fensteraussehen so anpassen kann, dass es nicht wie ein totaler Fremdkörper auf diesem stylischen Desktop wirkt?

    Ich bin auch schon auf der Suche nach einer Lösung,
    vielleicht hilft das hier:
    http://ubuntuforums.org/showthread.php?t=99923

    Ich hab mal im Debianforum nachgefragt, da konnte mir geholfen werden:
    http://debianforum.de/forum/viewtopic.php?f=2&t=120037

  4. Hi trompetenkaefer,
    ich bin gerade dabei mit sidux (basiert auf Debian SID) in einer virtuellen Maschine (KVM) E17 zum Laufen zu bekommen. Leider schmiert E17 beim Start ab. Als Repository habe ich das von dir genannte eingetragen, dann natürlich aus dem SID Zweig.

    Installiert sind die aktuellsten Pakete von e17 und emodules-all. Gibt’s irgendwelche Kniffe die man bei der Installation bzw. Start von E17 berücksichtigen muss?

    Ciao
    bluelupo

    • Ist GDM/KDM dein Loginmanager oder Entrance?
      Bei Entrance schmiert E17 leider beim starten ab…

      Grüße
      trompetenkaefer

    • Alex
    • 24. Oktober 2011

    Bei mir funktioniert die Installation von e17 nicht, da etliche Abhängigkeiten nicht aufgelöst werden können.

    • Welche Meldung wird bei der Installation ausgegeben bzw. welche Abhängigkeiten werden nicht erfüllt?

        • alex
        • 7. November 2011

        root@debian:/home/default# apt-get install e17
        Paketlisten werden gelesen… Fertig
        Abhängigkeitsbaum wird aufgebaut
        Statusinformationen werden eingelesen… Fertig
        Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
        Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
        Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
        nicht erstellt wurden oder Incoming noch nicht verlassen haben.
        Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

        Die folgenden Pakete haben unerfüllte Abhängigkeiten:
        e17 : Hängt ab von: libecore-evas-svn-05 (>= 0.9.9.063) soll aber nicht installiert werden
        Hängt ab von: libecore-imf-svn-05 (>= 0.9.9.063) soll aber nicht installiert werden
        Hängt ab von: libecore-input-svn-05 (>= 0.9.9.063) soll aber nicht installiert werden
        Hängt ab von: libecore-x-svn-05 (>= 0.9.9.063) soll aber nicht installiert werden
        Hängt ab von: libedbus-svn-05 (>= 0.5.0.063) soll aber nicht installiert werden
        Hängt ab von: libedje-svn-05 (>= 0.9.92.063) soll aber nicht installiert werden
        Hängt ab von: libeet1 (>= 1.2.3) soll aber nicht installiert werden
        Hängt ab von: libevas-svn-05 (>= 0.9.9.063) soll aber nicht installiert werden
        Hängt ab von: libevas-svn-05-engine-software-x11
        Hängt ab von: libedje-bin soll aber nicht installiert werden
        E: Beschädigte Pakete
        root@debian:/home/default#

    • Volker Scheven
    • 7. November 2011

    Vielen Dank für das HowTo.
    Ich mag E17 sehr, habe aber nicht gewußt, wie man das bei Debian installiert.
    Dein Blog, ist im übrigen ausgezeichnet.

  5. Schöner Blog.

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s

%d Bloggern gefällt das: